Power Input Troubleshooting of Copilot Reboots

Power Input Troubleshooting of Copilot Reboots

This document discusses the diagnosis and resolution for situations where a copilot reboot is triggered by activation of other electrical accessories. For example, the copilot reboots when the horn is used, or when a specific air conditioner unit is switched on or off.

Electrical Cause

If the Transportant power input is sharing the same fuse or bus bar with other accessories, such as a horn or air conditioner, those other accessories can impact the available input voltage supplied to the Transportant system. 
V4 copilots are sensitive to input voltage below 10.9 V in the default installation using a single Ethernet cable. This can be improved by using a power adapter cable ("pigtail"), in which case V4 copilots can withstand input voltages down to 10.0 V. Even transitory drops of input voltage below these thresholds can trigger a reboot of the copilot.
When the amount of current traveling through a wire increases, the voltage decreases proportionally. For example, in a wire with 12 V input supply and 1 ohm resistance, increasing the current drawn through the wire by 1 amp will cause a 1 V drop of voltage. Increasing the current draw by 2 amps will likewise cause a 2 V drop.
Motor accessories such as fans and many horns tend to cause hard transient drops in voltage because the initial current required to get the motor moving is significant (although the required current drops off afterwards.) These will not cause a voltage drop across the entire bus, but just the specific electrical segment the accessories are connected to.

Diagnosis

It is possible to confirm a drop of input voltage as a cause of copilot reboots with the careful use of a fast multimeter.  We need two specific tools:
  1. An Ethernet cable that you have modified (see below) to allow use with a multimeter. The cable will be plugged into one of the power over Ethernet (PoE) ports on the attendant.
  2. A multimeter that is fairly fast. It needs to be able to accurately capture the minimum voltage present on the PoE port, even if the drop is transient. Here is one multimeter that is believed to meet this requirement.
Here is how to modify the Ethernet cable mentioned above and to connect a multimeter to it:
  1. Cut an Ethernet cable in half. Discard one half.
  2. On the cut end of the other half, strip back the sheath to get to the colored wires inside.
  3. Strip the following four wires: blue, blue/white, brown, and brown/white.
  4. Twist together the blue & blue/white wires. Crimp or solder an alligator clip to them.
  5. Twist together the brown & brown/white wires. Crimp or solder an alligator clip to them.
  6. Attach the multimeter to the alligator clips.
To measure the voltage available to the copilot, the Transportant system must be in active mode. All PoE ports should have solid green lights illuminated. Active mode can be triggered by bringing the bus online, for example by  briefly moving the ignition key to the accessories position.
With the system in active mode and a modified Ethernet cable plugged in to a port on the attendant, note the minimum observed voltage. Then activate all accessories on the bus (horn, air conditioning, fans, etc.) and continue to observe the voltage. If the minimum input voltage ever drops, however briefly, below the 10.9 V or 10.0 V thresholds as described above, we can confirm low input voltage as a cause of copilot reboot.

Resolution

The simplest resolution is to move the attendant's power input connection to a different bus bar that is not shared with the air conditioning, horn, or any other power-hungry accessory.
If you have not already installed a power adapter, do so.
The other bus bars should be monitored at the same time to watch for system-wide voltage drop. If the entire bus voltage drops significantly, then moving the attendant power to another bar will not resolve the problem. That would mean that there is an issue with the alternator, belt, or tensioner, especially if there is an accompanying squeal from the belts.
    • Related Articles

    • Copilot Does Not Turn On

      If the copilot does not turn on at all as expected, here is what to do. Try the following steps in turn until the copilot comes on and stays on. How to fix it If the bus is not online, bring it online. Find the cable that connects the copilot to the ...
    • Copilot Stuck on Waiting for Network

      It is not uncommon to see the message "waiting for network" on a copilot screen for a few moments. However, if this message remains for more than five minutes, that indicates a problem. How to fix it If the bus is not online, bring it online. Confirm ...
    • Copilot Stuck on Android Recovery Screen

      Symptom Occasionally you might see a copilot stuck on the Android recovery screen. It looks like this: Android recovery screen It might be stuck there forever, or the copilot might frequently return to it. What to do The most common reason for its ...
    • A Video Guide to Troubleshooting

      In this video, we'll provide you with essential troubleshooting tips for using the Transportant system. You'll learn how to identify and resolve common issues, perform basic system checks, and utilize support resources effectively. This tutorial is ...
    • Can No Longer Log In to Dashboard

      Did you used to be able to log in to the dashboard, but no longer can? Here's how to fix that. How to fix it Open the log in page and enter the email address associated with your account. This is usually your work email. Press the "send me a link" ...